summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorReid Spencer <rspencer@reidspencer.com>2006-07-28 22:50:07 +0000
committerReid Spencer <rspencer@reidspencer.com>2006-07-28 22:50:07 +0000
commitceaf1c33c036ac33e3bc5aa97c57547e30627742 (patch)
tree5cccfd72e54ab00ccc5f502adccc1392287423a2 /autoconf/configure.ac
parent1bebfb5ae4c240064beffe3232402ea68b110510 (diff)
downloadllvm-ceaf1c33c036ac33e3bc5aa97c57547e30627742.tar.gz
llvm-ceaf1c33c036ac33e3bc5aa97c57547e30627742.tar.bz2
llvm-ceaf1c33c036ac33e3bc5aa97c57547e30627742.tar.xz
Fix the --with-extra-options to use the correct variable.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@29403 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 6d1624491d..4526c48dbe 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -337,10 +337,10 @@ dnl Specify extra build options
AC_ARG_WITH(extra-options,
AS_HELP_STRING([--with-extra-options],
[Specify addtional options to compile LLVM with]),,
- extraopts=default)
-case "$extraopts" in
+ withval=default)
+case "$withval" in
default) EXTRA_OPTIONS= ;;
- *) EXTRA_OPTIONS=$extraopts ;;
+ *) EXTRA_OPTIONS=$withval ;;
esac
AC_SUBST(EXTRA_OPTIONS,$EXTRA_OPTIONS)