summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorEvan Cheng <evan.cheng@apple.com>2006-06-20 22:16:32 +0000
committerEvan Cheng <evan.cheng@apple.com>2006-06-20 22:16:32 +0000
commitcf9be26e5d99c50b350aa8c5bf6ce6bc8322b213 (patch)
tree02c12e2023cbbca3be3d1caff744edd8a2d2973d /autoconf/configure.ac
parente3db4daa166d9ce7995555642129a8323b8c263a (diff)
downloadllvm-cf9be26e5d99c50b350aa8c5bf6ce6bc8322b213.tar.gz
llvm-cf9be26e5d99c50b350aa8c5bf6ce6bc8322b213.tar.bz2
llvm-cf9be26e5d99c50b350aa8c5bf6ce6bc8322b213.tar.xz
Added --with-extra-options=opts to specify additional options to build LLVM and run tests.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@28882 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 35b6988f85..690f18a729 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -325,6 +325,16 @@ case "$withval" in
*) AC_MSG_ERROR([Invalid path for --with-llvmgccdir. Provide full path]) ;;
esac
+dnl Specify extra build options
+AC_ARG_WITH(extra-options,
+ AS_HELP_STRING([--with-extra-options],
+ [Specify addtional options to compile LLVM with]),,
+ extraopts=default)
+case "$extraopts" in
+ default) EXTRA_OPTIONS= ;;
+ *) EXTRA_OPTIONS=$extraopts ;;
+esac
+AC_SUBST(EXTRA_OPTIONS,$EXTRA_OPTIONS)
dnl===-----------------------------------------------------------------------===
dnl===