summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorBrian Gaeke <gaeke@uiuc.edu>2004-01-16 21:31:22 +0000
committerBrian Gaeke <gaeke@uiuc.edu>2004-01-16 21:31:22 +0000
commitd05e39d6a64db0d2261b519642c193d61f1f9502 (patch)
tree9d4393b39596a970ea2ef8aae0c0d967e2762996 /autoconf/configure.ac
parent2f50a045fc71a37dcc94e9f9838e3c972c6cdd45 (diff)
downloadllvm-d05e39d6a64db0d2261b519642c193d61f1f9502.tar.gz
llvm-d05e39d6a64db0d2261b519642c193d61f1f9502.tar.bz2
llvm-d05e39d6a64db0d2261b519642c193d61f1f9502.tar.xz
Get paths to cc1 and cc1plus by asking llvm-gcc, and AC_SUBST them.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@10901 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index d9177a4f0d..369d26064f 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -360,6 +360,10 @@ then
LLVM_GCC_SANE=yes
fi
rm conftest.c
+ llvmcc1path=`"$LLVM_GCC_CHECK" --print-prog-name=cc1`
+ AC_SUBST(LLVMCC1,$llvmcc1path)
+ llvmcc1pluspath=`"$LLVM_GCC_CHECK" --print-prog-name=cc1plus`
+ AC_SUBST(LLVMCC1PLUS,$llvmcc1pluspath)
fi
AC_MSG_RESULT($LLVM_GCC_SANE)
if test "$LLVM_GCC_SANE" = "no"