summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorNick Lewycky <nicholas@mxc.ca>2009-01-20 00:51:40 +0000
committerNick Lewycky <nicholas@mxc.ca>2009-01-20 00:51:40 +0000
commitf514e2d28f3ff1d0d959522bfa0834d023d91aaf (patch)
treef2119e55c981549a2859c54b5e7350a335ff94d5 /autoconf/configure.ac
parentd0deec20f6a77b3b22af9f91dd3e30314c5264bc (diff)
downloadllvm-f514e2d28f3ff1d0d959522bfa0834d023d91aaf.tar.gz
llvm-f514e2d28f3ff1d0d959522bfa0834d023d91aaf.tar.bz2
llvm-f514e2d28f3ff1d0d959522bfa0834d023d91aaf.tar.xz
Make the Interpreter use libffi if it's available. Patch from Alexei Svitkine!
This requires a rebuild of 'configure' itself. I will be committing that next, but built with the wrong version of autoconf. Somebody who has the right one, please update it. As a side-note, because of the way autoconf works, all built tools will link against libffi, not just lli. If you know how to fix this, please let me know ... git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@62553 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index c9bd8f2513..b9585def2c 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -717,6 +717,11 @@ AC_SEARCH_LIBS(dlopen,dl,AC_DEFINE([HAVE_DLOPEN],[1],
[Define if dlopen() is available on this platform.]),
AC_MSG_WARN([dlopen() not found - disabling plugin support]))
+dnl libffi is optional; used to call external functions from the interpreter
+AC_SEARCH_LIBS(ffi_call,ffi,AC_DEFINE([HAVE_LIBFFI],[1],
+ [Define to 1 if you have the libffi library (-lffi).]),
+ AC_MSG_WARN([libffi not found - disabling external calls from interpreter]))
+
dnl mallinfo is optional; the code can compile (minus features) without it
AC_SEARCH_LIBS(mallinfo,malloc,AC_DEFINE([HAVE_MALLINFO],[1],
[Define if mallinfo() is available on this platform.]))
@@ -779,6 +784,10 @@ else
AC_SUBST(HAVE_PTHREAD, 0)
fi
+dnl Debian vs. the world.
+AC_CHECK_HEADER(ffi/ffi.h, AC_DEFINE(FFI_HEADER, ["ffi/ffi.h"], [Path to ffi.h]))
+AC_CHECK_HEADER(ffi.h, AC_DEFINE(FFI_HEADER, ["ffi.h"], [Path to ffi.h]))
+
dnl===-----------------------------------------------------------------------===
dnl===
dnl=== SECTION 7: Check for types and structures