summaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-09-26 19:48:03 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-09-26 19:48:03 +0000
commitdbc2e856fce973243d2dfba88d573d3c88f06020 (patch)
tree979cbee4a308e05095045e55f4fc1c399eb2b153 /examples/CMakeLists.txt
parentdfe8c84e1e7be1ec4f7303d3d056fb106ab28437 (diff)
downloadllvm-dbc2e856fce973243d2dfba88d573d3c88f06020.tar.gz
llvm-dbc2e856fce973243d2dfba88d573d3c88f06020.tar.bz2
llvm-dbc2e856fce973243d2dfba88d573d3c88f06020.tar.xz
CMake: Builds all examples. Corrected name of CBackend target.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@56682 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 392e59d989..fa91149755 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1 +1,11 @@
-add_subdirectory(Fibonacci) \ No newline at end of file
+add_subdirectory(BrainF)
+add_subdirectory(Fibonacci)
+add_subdirectory(HowToUseJIT)
+add_subdirectory(ModuleMaker)
+
+include(CheckIncludeFile)
+check_include_file(pthread.h HAVE_PTHREAD_H)
+
+if( HAVE_PTHREAD_H )
+ add_subdirectory(ParallelJIT)
+endif( HAVE_PTHREAD_H )