summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Bogner <mail@justinbogner.com>2014-03-12 20:14:05 +0000
committerJustin Bogner <mail@justinbogner.com>2014-03-12 20:14:05 +0000
commit02da814a94c043452e3ad10915e8ba366218e925 (patch)
treefee3f84f130198d1e8acbb4539b35c27d77a4957 /lib/CMakeLists.txt
parent7eb747e373344eeaf4486621cbb0cfd78e349033 (diff)
downloadllvm-02da814a94c043452e3ad10915e8ba366218e925.tar.gz
llvm-02da814a94c043452e3ad10915e8ba366218e925.tar.bz2
llvm-02da814a94c043452e3ad10915e8ba366218e925.tar.xz
Profile: Add a library for the instrumentation based profiling format
This provides a library to work with the instrumentation based profiling format that is used by clang's -fprofile-instr-* options and by the llvm-profdata tool. This is a binary format, rather than the textual one that's currently in use. The tests are in the subsequent commits that use this. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@203703 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 9367f55313..a4496f9e58 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -16,3 +16,4 @@ add_subdirectory(ExecutionEngine)
add_subdirectory(Target)
add_subdirectory(AsmParser)
add_subdirectory(LineEditor)
+add_subdirectory(Profile)