summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-02-18 22:06:14 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-02-18 22:06:14 +0000
commit6d857ca4d71548f5cdb57b106cc1a12fc2c93e9d (patch)
treeb9cee0ab1c312b750d15cdcaf557671ba8949ccc /lib/CMakeLists.txt
parentba05c01dabc40373760a20c874103fc58d4377f0 (diff)
downloadllvm-6d857ca4d71548f5cdb57b106cc1a12fc2c93e9d.tar.gz
llvm-6d857ca4d71548f5cdb57b106cc1a12fc2c93e9d.tar.bz2
llvm-6d857ca4d71548f5cdb57b106cc1a12fc2c93e9d.tar.xz
Move library stuff out of the toplevel CMakeLists.txt file.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@125968 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
new file mode 100644
index 0000000000..e2838c373a
--- /dev/null
+++ b/lib/CMakeLists.txt
@@ -0,0 +1,14 @@
+# `Support' library is added on the top-level CMakeLists.txt
+
+add_subdirectory(VMCore)
+add_subdirectory(CodeGen)
+add_subdirectory(Bitcode)
+add_subdirectory(Transforms)
+add_subdirectory(Linker)
+add_subdirectory(Analysis)
+add_subdirectory(MC)
+add_subdirectory(Object)
+add_subdirectory(ExecutionEngine)
+add_subdirectory(Target)
+add_subdirectory(AsmParser)
+add_subdirectory(Archive)