summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Bogner <mail@justinbogner.com>2014-03-21 17:24:48 +0000
committerJustin Bogner <mail@justinbogner.com>2014-03-21 17:24:48 +0000
commitc0f3b725555df38fc4d9be6154af95dad83694f8 (patch)
tree9b55483376292140b20656648ed1254eebff2e83 /lib/CMakeLists.txt
parent6c22b041da771c2cccc004d97fd49543f0ebf168 (diff)
downloadllvm-c0f3b725555df38fc4d9be6154af95dad83694f8.tar.gz
llvm-c0f3b725555df38fc4d9be6154af95dad83694f8.tar.bz2
llvm-c0f3b725555df38fc4d9be6154af95dad83694f8.tar.xz
ProfileData: Introduce the InstrProfReader interface and a text reader
This introduces the ProfileData library and updates llvm-profdata to use this library for reading profiles. InstrProfReader is an abstract base class that will be subclassed for both the raw instrprof data from compiler-rt and the efficient instrprof format that will be used for PGO. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@204482 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 9367f55313..fab1c8747b 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -16,3 +16,4 @@ add_subdirectory(ExecutionEngine)
add_subdirectory(Target)
add_subdirectory(AsmParser)
add_subdirectory(LineEditor)
+add_subdirectory(ProfileData)