summaryrefslogtreecommitdiff
path: root/lib/CodeGen/AsmPrinter/CMakeLists.txt
diff options
context:
space:
mode:
authorDevang Patel <dpatel@apple.com>2011-04-12 22:53:02 +0000
committerDevang Patel <dpatel@apple.com>2011-04-12 22:53:02 +0000
commit3cbee30eacd5d918a00f21c08dbd10ee9ae73925 (patch)
treee2d123dd12f075fcc9ca71ab58d043f557557c28 /lib/CodeGen/AsmPrinter/CMakeLists.txt
parentd5f323d70bd2d9bc8a63a68bfe439a69e0104bbf (diff)
downloadllvm-3cbee30eacd5d918a00f21c08dbd10ee9ae73925.tar.gz
llvm-3cbee30eacd5d918a00f21c08dbd10ee9ae73925.tar.bz2
llvm-3cbee30eacd5d918a00f21c08dbd10ee9ae73925.tar.xz
This mechanical patch moves type handling into CompileUnit from DwarfDebug. In case of multiple compile unit in one object file, each compile unit is responsible for its own set of type entries anyway. This refactoring makes this obvious.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@129402 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/AsmPrinter/CMakeLists.txt')
-rw-r--r--lib/CodeGen/AsmPrinter/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/AsmPrinter/CMakeLists.txt b/lib/CodeGen/AsmPrinter/CMakeLists.txt
index 1377e4dd73..d2be5525d7 100644
--- a/lib/CodeGen/AsmPrinter/CMakeLists.txt
+++ b/lib/CodeGen/AsmPrinter/CMakeLists.txt
@@ -5,6 +5,7 @@ add_llvm_library(LLVMAsmPrinter
AsmPrinterInlineAsm.cpp
DIE.cpp
DwarfCFIException.cpp
+ DwarfCompileUnit.cpp
DwarfDebug.cpp
DwarfException.cpp
DwarfTableException.cpp