summaryrefslogtreecommitdiff
path: root/lib/CodeGen/AsmPrinter/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Blaikie <dblaikie@gmail.com>2014-04-25 21:34:35 +0000
committerDavid Blaikie <dblaikie@gmail.com>2014-04-25 21:34:35 +0000
commit891481f89dc448ec28dbee0fa483a720bd91ea07 (patch)
treebacbd42db7f60b6e11d25d544c8d76408ca45b1b /lib/CodeGen/AsmPrinter/CMakeLists.txt
parentc87722ce4beb2975e86d7225c9cba1f600c266e9 (diff)
downloadllvm-891481f89dc448ec28dbee0fa483a720bd91ea07.tar.gz
llvm-891481f89dc448ec28dbee0fa483a720bd91ea07.tar.bz2
llvm-891481f89dc448ec28dbee0fa483a720bd91ea07.tar.xz
Encapsulate the DWARF string pool in a separate type.
Pulls out some more code from some of the rather monolithic DWARF classes. Unlike the address table, the string table won't move up into DwarfDebug - each DWARF file has its own string table (but there can be only one address table). git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@207277 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/AsmPrinter/CMakeLists.txt')
-rw-r--r--lib/CodeGen/AsmPrinter/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/AsmPrinter/CMakeLists.txt b/lib/CodeGen/AsmPrinter/CMakeLists.txt
index b4f8dc2bd8..a9afc84e84 100644
--- a/lib/CodeGen/AsmPrinter/CMakeLists.txt
+++ b/lib/CodeGen/AsmPrinter/CMakeLists.txt
@@ -11,6 +11,7 @@ add_llvm_library(LLVMAsmPrinter
DwarfDebug.cpp
DwarfException.cpp
DwarfFile.cpp
+ DwarfStringPool.cpp
DwarfUnit.cpp
ErlangGCPrinter.cpp
OcamlGCPrinter.cpp