summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Trick <atrick@apple.com>2010-10-22 23:09:15 +0000
committerAndrew Trick <atrick@apple.com>2010-10-22 23:09:15 +0000
commit14e8d71cc945034d4ee6e76be00e00f14efac62f (patch)
treea949a75ee28e7ab9e441d23e1765a97c1e6d5c60 /lib/CodeGen/CMakeLists.txt
parentc9db3314333c34458f6648088cdabbbc96696e9a (diff)
downloadllvm-14e8d71cc945034d4ee6e76be00e00f14efac62f.tar.gz
llvm-14e8d71cc945034d4ee6e76be00e00f14efac62f.tar.bz2
llvm-14e8d71cc945034d4ee6e76be00e00f14efac62f.tar.xz
This is a prototype of an experimental register allocation
framework. It's purpose is not to improve register allocation per se, but to make it easier to develop powerful live range splitting. I call it the basic allocator because it is as simple as a global allocator can be but provides the building blocks for sophisticated register allocation with live range splitting. A minimal implementation is provided that trivially spills whenever it runs out of registers. I'm checking in now to get high-level design and style feedback. I've only done minimal testing. The next step is implementing a "greedy" allocation algorithm that does some register reassignment and makes better splitting decisions. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@117174 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index dbf5dca3f2..effd03c351 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -21,6 +21,7 @@ add_llvm_library(LLVMCodeGen
LatencyPriorityQueue.cpp
LiveInterval.cpp
LiveIntervalAnalysis.cpp
+ LiveIntervalUnion.cpp
LiveStackAnalysis.cpp
LiveVariables.cpp
LiveRangeEdit.cpp
@@ -55,6 +56,7 @@ add_llvm_library(LLVMCodeGen
ProcessImplicitDefs.cpp
PrologEpilogInserter.cpp
PseudoSourceValue.cpp
+ RegAllocBasic.cpp
RegAllocFast.cpp
RegAllocLinearScan.cpp
RegAllocPBQP.cpp