summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2011-11-12 22:39:45 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2011-11-12 22:39:45 +0000
commit799c1ede712854f56ed85b74702e611b88b49436 (patch)
treee4cc372b120f067a4358f3af4f7a54e350e42a53 /lib/CodeGen/CMakeLists.txt
parentfe9dd87783601db515e39619508ea8fb2c017557 (diff)
downloadllvm-799c1ede712854f56ed85b74702e611b88b49436.tar.gz
llvm-799c1ede712854f56ed85b74702e611b88b49436.tar.bz2
llvm-799c1ede712854f56ed85b74702e611b88b49436.tar.xz
Delete the linear scan register allocator.
RegAllocGreedy has been the default for six months now. Deleting RegAllocLinearScan makes it possible to also delete VirtRegRewriter and clean up the spiller code. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@144475 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 1bbe7a0375..1c39cd22f2 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -70,7 +70,6 @@ add_llvm_library(LLVMCodeGen
RegAllocBasic.cpp
RegAllocFast.cpp
RegAllocGreedy.cpp
- RegAllocLinearScan.cpp
RegAllocPBQP.cpp
RegisterClassInfo.cpp
RegisterCoalescer.cpp