summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2010-07-20 15:41:07 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2010-07-20 15:41:07 +0000
commit8ae0263471cc29c5f8278ee1ea5b678042ec6dce (patch)
tree086272410c6173aea012a57e52f095fc01c82fda /lib/CodeGen/CMakeLists.txt
parent26ede6834e8a435bd7a6670cb34f64d3f8e2599d (diff)
downloadllvm-8ae0263471cc29c5f8278ee1ea5b678042ec6dce.tar.gz
llvm-8ae0263471cc29c5f8278ee1ea5b678042ec6dce.tar.bz2
llvm-8ae0263471cc29c5f8278ee1ea5b678042ec6dce.tar.xz
Beginning SplitKit - utility classes for live range splitting.
This is a work in progress. So far we have some basic loop analysis to help determine where it is useful to split a live range around a loop. The actual loop splitting code from Splitter.cpp is also going to move in here. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@108842 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index ba6be3ce78..4e377f941c 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -68,6 +68,7 @@ add_llvm_library(LLVMCodeGen
SjLjEHPrepare.cpp
SlotIndexes.cpp
Spiller.cpp
+ SplitKit.cpp
Splitter.cpp
StackProtector.cpp
StackSlotColoring.cpp