summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2012-07-26 18:38:11 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2012-07-26 18:38:11 +0000
commit9f63e104271eb91e545fa8cdb16fb9e10a8a9578 (patch)
tree129292c1e42af3731aa15b38dec315b74795fed6 /lib/CodeGen/CMakeLists.txt
parent27db99fcee85939f0b7580ad55303c4c60a3b98d (diff)
downloadllvm-9f63e104271eb91e545fa8cdb16fb9e10a8a9578.tar.gz
llvm-9f63e104271eb91e545fa8cdb16fb9e10a8a9578.tar.bz2
llvm-9f63e104271eb91e545fa8cdb16fb9e10a8a9578.tar.xz
Start scaffolding for a MachineTraceMetrics analysis pass.
This is still a work in progress. Out-of-order CPUs usually execute instructions from multiple basic blocks simultaneously, so it is necessary to look at longer traces when estimating the performance effects of code transformations. The MachineTraceMetrics analysis will pick a typical trace through a given basic block and provide performance metrics for the trace. Metrics will include: - Instruction count through the trace. - Issue count per functional unit. - Critical path length, and per-instruction 'slack'. These metrics can be used to determine the performance limiting factor when executing the trace, and how it will be affected by a code transformation. Initially, this will be used by the early if-conversion pass. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@160796 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index d240389d7c..2e189ad7e7 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -61,6 +61,7 @@ add_llvm_library(LLVMCodeGen
MachineSSAUpdater.cpp
MachineScheduler.cpp
MachineSink.cpp
+ MachineTraceMetrics.cpp
MachineVerifier.cpp
OcamlGC.cpp
OptimizePHIs.cpp