summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2010-10-14 23:49:52 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2010-10-14 23:49:52 +0000
commita17768f5822ab62bc18608e5ba473187bf726b84 (patch)
tree8ebad1e5fd484b5b49f7629b19c5febf8c7ad1fc /lib/CodeGen/CMakeLists.txt
parent53e7dcbd47c6ca34c0cd00c35b09ee5a2be7afe1 (diff)
downloadllvm-a17768f5822ab62bc18608e5ba473187bf726b84.tar.gz
llvm-a17768f5822ab62bc18608e5ba473187bf726b84.tar.bz2
llvm-a17768f5822ab62bc18608e5ba473187bf726b84.tar.xz
Create a new LiveRangeEdit class to keep track of the new registers created when
splitting or spillling, and to help with rematerialization. Use LiveRangeEdit in InlineSpiller and SplitKit. This will eventually make it possible to share remat code between InlineSpiller and SplitKit. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@116543 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index a2e04ffe65..dbf5dca3f2 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -23,6 +23,7 @@ add_llvm_library(LLVMCodeGen
LiveIntervalAnalysis.cpp
LiveStackAnalysis.cpp
LiveVariables.cpp
+ LiveRangeEdit.cpp
LocalStackSlotAllocation.cpp
LowerSubregs.cpp
MachineBasicBlock.cpp