summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2011-09-13 01:34:21 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2011-09-13 01:34:21 +0000
commitb5a457c4cbc71db6ae313ef1bf8eadac65767ab0 (patch)
treeaad27894a39c0885259b2161e48183b6507c8bdf /lib/CodeGen/CMakeLists.txt
parent1582e7f1e255c19595f82cb447e52869196dec58 (diff)
downloadllvm-b5a457c4cbc71db6ae313ef1bf8eadac65767ab0.tar.gz
llvm-b5a457c4cbc71db6ae313ef1bf8eadac65767ab0.tar.bz2
llvm-b5a457c4cbc71db6ae313ef1bf8eadac65767ab0.tar.xz
Extract live range calculations from SplitKit.
SplitKit will soon need two copies of these data structures, and the algorithms will also be useful when LiveIntervalAnalysis becomes independent of LiveVariables. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@139572 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index af0f7f530c..06fc3f3277 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -30,6 +30,7 @@ add_llvm_library(LLVMCodeGen
LiveIntervalUnion.cpp
LiveStackAnalysis.cpp
LiveVariables.cpp
+ LiveRangeCalc.cpp
LiveRangeEdit.cpp
LocalStackSlotAllocation.cpp
LowerSubregs.cpp