summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2010-11-30 02:17:10 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2010-11-30 02:17:10 +0000
commitbb7b23f5b79a7ca2aa62faa1a6078428af597234 (patch)
tree0f6a7a72f1419cb56611adbb6291107707c208f8 /lib/CodeGen/CMakeLists.txt
parentd7b6a989a7cdea0cbfe1a2b7c6f46d5d102054f2 (diff)
downloadllvm-bb7b23f5b79a7ca2aa62faa1a6078428af597234.tar.gz
llvm-bb7b23f5b79a7ca2aa62faa1a6078428af597234.tar.bz2
llvm-bb7b23f5b79a7ca2aa62faa1a6078428af597234.tar.xz
Stub out a new LiveDebugVariables pass.
This analysis is going to run immediately after LiveIntervals. It will stay alive during register allocation and keep track of user variables mentioned in DBG_VALUE instructions. When the register allocator is moving values between registers and the stack, it is very hard to keep track of DBG_VALUE instructions. We usually get it wrong. This analysis maintains a data structure that makes it easy to update DBG_VALUE instructions. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@120385 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 7a36c5137a..ed7ec6ea50 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -20,6 +20,7 @@ add_llvm_library(LLVMCodeGen
IntrinsicLowering.cpp
LLVMTargetMachine.cpp
LatencyPriorityQueue.cpp
+ LiveDebugVariables.cpp
LiveInterval.cpp
LiveIntervalAnalysis.cpp
LiveIntervalUnion.cpp