summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJiangning Liu <jiangning.liu@arm.com>2014-06-13 22:57:59 +0000
committerJiangning Liu <jiangning.liu@arm.com>2014-06-13 22:57:59 +0000
commitc5bc067a0fb05fe36761bb280d630dce5611f400 (patch)
tree85ee401bdc015e66816aad6babcd46198420941e /lib/CodeGen/CMakeLists.txt
parent7354a3fe576b34919b0752306fd1b382f879a115 (diff)
downloadllvm-c5bc067a0fb05fe36761bb280d630dce5611f400.tar.gz
llvm-c5bc067a0fb05fe36761bb280d630dce5611f400.tar.bz2
llvm-c5bc067a0fb05fe36761bb280d630dce5611f400.tar.xz
Move GlobalMerge from Transform to CodeGen.
This patch is to move GlobalMerge pass from Transform/Scalar to CodeGen, because GlobalMerge depends on TargetMachine. In the mean time, the macro INITIALIZE_TM_PASS is also moved to CodeGen/Passes.h. With this fix we can avoid making libScalarOpts depend on libCodeGen. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@210951 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index b158925f27..57c24e823c 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -22,6 +22,7 @@ add_llvm_library(LLVMCodeGen
GCMetadata.cpp
GCMetadataPrinter.cpp
GCStrategy.cpp
+ GlobalMerge.cpp
IfConversion.cpp
InlineSpiller.cpp
InterferenceCache.cpp