summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2012-01-11 22:28:30 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2012-01-11 22:28:30 +0000
commitccc9581e8b79b4216cb1143344bdae9342722d5d (patch)
tree98af5f3f04a71b3b66f32918567dcb4dbc1cd1f5 /lib/CodeGen/CMakeLists.txt
parente15f421a9acd18ca71fed382ac09f7367b6a72f6 (diff)
downloadllvm-ccc9581e8b79b4216cb1143344bdae9342722d5d.tar.gz
llvm-ccc9581e8b79b4216cb1143344bdae9342722d5d.tar.bz2
llvm-ccc9581e8b79b4216cb1143344bdae9342722d5d.tar.xz
Move RegAllocBase into its own cpp file separate from RABasic.
No functional change. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@147972 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 7fa5e47f9e..65d4971ba3 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -69,6 +69,7 @@ add_llvm_library(LLVMCodeGen
ProcessImplicitDefs.cpp
PrologEpilogInserter.cpp
PseudoSourceValue.cpp
+ RegAllocBase.cpp
RegAllocBasic.cpp
RegAllocFast.cpp
RegAllocGreedy.cpp