summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Trick <atrick@apple.com>2013-12-13 18:36:56 +0000
committerAndrew Trick <atrick@apple.com>2013-12-13 18:36:56 +0000
commitedf1070ca74f7d646bce2c66db9f443d09e7d1d3 (patch)
tree6807302b609e69fdf3ecef77a99172bc61cf1ff6 /lib/CodeGen/CMakeLists.txt
parent513a00db789a07510f7ce715e92e53343a9d8d53 (diff)
downloadllvm-edf1070ca74f7d646bce2c66db9f443d09e7d1d3.tar.gz
llvm-edf1070ca74f7d646bce2c66db9f443d09e7d1d3.tar.bz2
llvm-edf1070ca74f7d646bce2c66db9f443d09e7d1d3.tar.xz
Convert liveness tracking to work on a sub-register level instead of just register units.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@197253 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 10cc9fff9a..0beca0ceed 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -35,7 +35,7 @@ add_llvm_library(LLVMCodeGen
LiveRangeCalc.cpp
LiveRangeEdit.cpp
LiveRegMatrix.cpp
- LiveRegUnits.cpp
+ LivePhysRegs.cpp
LiveStackAnalysis.cpp
LiveVariables.cpp
LocalStackSlotAllocation.cpp