summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorBob Wilson <bob.wilson@apple.com>2010-02-12 01:30:21 +0000
committerBob Wilson <bob.wilson@apple.com>2010-02-12 01:30:21 +0000
commitfe61fb1e1082c81653ed78efd6d471592a2e57ad (patch)
treedf0bb339b5cb79a8d22e66430b920e47fae100a5 /lib/CodeGen/CMakeLists.txt
parentccfa1db5380fd3089fc68f3ed9ccfe6a41d7a309 (diff)
downloadllvm-fe61fb1e1082c81653ed78efd6d471592a2e57ad.tar.gz
llvm-fe61fb1e1082c81653ed78efd6d471592a2e57ad.tar.bz2
llvm-fe61fb1e1082c81653ed78efd6d471592a2e57ad.tar.xz
Add a new pass on machine instructions to optimize away PHI cycles that
reduce down to a single value. InstCombine already does this transformation but DAG legalization may introduce new opportunities. This has turned out to be important for ARM where 64-bit values are split up during type legalization: InstCombine is not able to remove the PHI cycles on the 64-bit values but the separate 32-bit values can be optimized. I measured the compile time impact of this (running llc on 176.gcc) and it was not significant. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@95951 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 9fcbea9437..46d3268259 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -39,6 +39,7 @@ add_llvm_library(LLVMCodeGen
ObjectCodeEmitter.cpp
OcamlGC.cpp
OptimizeExts.cpp
+ OptimizePHIs.cpp
PHIElimination.cpp
Passes.cpp
PostRASchedulerList.cpp