summaryrefslogtreecommitdiff
path: root/lib/DebugInfo/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Kramer <benny.kra@googlemail.com>2011-09-14 01:09:52 +0000
committerBenjamin Kramer <benny.kra@googlemail.com>2011-09-14 01:09:52 +0000
commit358f4fd9ee078b3c79597fc688855fb48bc1f356 (patch)
treeb8af6f225d18bd09d8c1a67e4a7bfed76175aefd /lib/DebugInfo/CMakeLists.txt
parent836623420dbf5eb3a3facde2841179ded91ab55b (diff)
downloadllvm-358f4fd9ee078b3c79597fc688855fb48bc1f356.tar.gz
llvm-358f4fd9ee078b3c79597fc688855fb48bc1f356.tar.bz2
llvm-358f4fd9ee078b3c79597fc688855fb48bc1f356.tar.xz
DWARF: Port support for parsing .debug_aranges section from LLDB and wire it up to llvm-dwarfdump.
This is only one half of it, the part that caches address ranges from the DIEs when .debug_aranges is not available will be ported soon. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@139680 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/DebugInfo/CMakeLists.txt')
-rw-r--r--lib/DebugInfo/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/DebugInfo/CMakeLists.txt b/lib/DebugInfo/CMakeLists.txt
index 73e5897e71..91d20dd70c 100644
--- a/lib/DebugInfo/CMakeLists.txt
+++ b/lib/DebugInfo/CMakeLists.txt
@@ -4,6 +4,8 @@ add_llvm_library(LLVMDebugInfo
DWARFCompileUnit.cpp
DWARFContext.cpp
DWARFDebugAbbrev.cpp
+ DWARFDebugArangeSet.cpp
+ DWARFDebugAranges.cpp
DWARFDebugInfoEntry.cpp
DWARFFormValue.cpp
)