summaryrefslogtreecommitdiff
path: root/lib/DebugInfo/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Blaikie <dblaikie@gmail.com>2013-06-19 21:37:13 +0000
committerDavid Blaikie <dblaikie@gmail.com>2013-06-19 21:37:13 +0000
commit3df7d2f70bb316ebeec8a8c862b3da5386fbb145 (patch)
treeefdb44c6da2587da53aee3079c914e688692fc13 /lib/DebugInfo/CMakeLists.txt
parentba54bca472a15d0657e1b88776f7069042b60b4e (diff)
downloadllvm-3df7d2f70bb316ebeec8a8c862b3da5386fbb145.tar.gz
llvm-3df7d2f70bb316ebeec8a8c862b3da5386fbb145.tar.bz2
llvm-3df7d2f70bb316ebeec8a8c862b3da5386fbb145.tar.xz
llvm-dwarfdump: Add support for dumping the .debug_loc section
This is a basic implementation - we still don't have any support (that I know of) for dumping DWARF expressions in a meaningful way, so the location information itself is just printed as a sequence of bytes as we do elsewhere. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@184361 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/DebugInfo/CMakeLists.txt')
-rw-r--r--lib/DebugInfo/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/DebugInfo/CMakeLists.txt b/lib/DebugInfo/CMakeLists.txt
index e97455abac..4a6221d454 100644
--- a/lib/DebugInfo/CMakeLists.txt
+++ b/lib/DebugInfo/CMakeLists.txt
@@ -9,6 +9,7 @@ add_llvm_library(LLVMDebugInfo
DWARFDebugFrame.cpp
DWARFDebugInfoEntry.cpp
DWARFDebugLine.cpp
+ DWARFDebugLoc.cpp
DWARFDebugRangeList.cpp
DWARFFormValue.cpp
)