summaryrefslogtreecommitdiff
path: root/lib/ExecutionEngine/CMakeLists.txt
diff options
context:
space:
mode:
authorFilip Pizlo <fpizlo@apple.com>2013-05-21 20:24:07 +0000
committerFilip Pizlo <fpizlo@apple.com>2013-05-21 20:24:07 +0000
commita4ea4a72031809911d77f543eb65175e00fe914e (patch)
treec52901daaada23258b60c45f1dc37ffd036d10b7 /lib/ExecutionEngine/CMakeLists.txt
parent50f19a906a9d5e42d7707b54a11c0f0c9265fc1f (diff)
downloadllvm-a4ea4a72031809911d77f543eb65175e00fe914e.tar.gz
llvm-a4ea4a72031809911d77f543eb65175e00fe914e.tar.bz2
llvm-a4ea4a72031809911d77f543eb65175e00fe914e.tar.xz
Put RTDyldMemoryManager into its own file, and make it linked into
libExecutionEngine. Move method implementations that aren't specific to allocation out of SectionMemoryManager and into RTDyldMemoryManager. This is in preparation for exposing RTDyldMemoryManager through the C API. This is a fixed version of r182407 and r182411. That first revision broke builds because I forgot to move the conditional includes of various POSIX headers from SectionMemoryManager into RTDyldMemoryManager. Those includes are necessary because of how getPointerToNamedFunction works around the glibc libc_nonshared.a thing. The latter revision still broke things because I forgot to include llvm/Config/config.h. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@182418 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ExecutionEngine/CMakeLists.txt')
-rw-r--r--lib/ExecutionEngine/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/ExecutionEngine/CMakeLists.txt b/lib/ExecutionEngine/CMakeLists.txt
index cb11bfe93c..3102c7bd58 100644
--- a/lib/ExecutionEngine/CMakeLists.txt
+++ b/lib/ExecutionEngine/CMakeLists.txt
@@ -3,6 +3,7 @@
add_llvm_library(LLVMExecutionEngine
ExecutionEngine.cpp
ExecutionEngineBindings.cpp
+ RTDyldMemoryManager.cpp
TargetSelect.cpp
)