summaryrefslogtreecommitdiff
path: root/lib/ExecutionEngine/JIT/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-09-10 21:14:25 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-09-10 21:14:25 +0000
commit4e9c939312ff73bd0c6a6485fd5f97012f5910fa (patch)
tree5ac7e42fde2303030a9af1183b7842986459bc45 /lib/ExecutionEngine/JIT/CMakeLists.txt
parentbb811a244567aa8a1522203f15588f4d001b7353 (diff)
downloadllvm-4e9c939312ff73bd0c6a6485fd5f97012f5910fa.tar.gz
llvm-4e9c939312ff73bd0c6a6485fd5f97012f5910fa.tar.bz2
llvm-4e9c939312ff73bd0c6a6485fd5f97012f5910fa.tar.xz
CMake: Get rid of LLVMLibDeps.cmake and export the libraries normally.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@113632 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ExecutionEngine/JIT/CMakeLists.txt')
-rw-r--r--lib/ExecutionEngine/JIT/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/ExecutionEngine/JIT/CMakeLists.txt b/lib/ExecutionEngine/JIT/CMakeLists.txt
index 42020d69af..d81b162a4a 100644
--- a/lib/ExecutionEngine/JIT/CMakeLists.txt
+++ b/lib/ExecutionEngine/JIT/CMakeLists.txt
@@ -11,3 +11,11 @@ add_llvm_library(LLVMJIT
OProfileJITEventListener.cpp
TargetSelect.cpp
)
+
+target_link_libraries(LLVMJIT
+ LLVMCodeGen
+ LLVMCore
+ LLVMExecutionEngine
+ LLVMMC
+ LLVMTarget
+ )