summaryrefslogtreecommitdiff
path: root/lib/ExecutionEngine/JIT/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2009-06-23 17:57:35 +0000
committerDouglas Gregor <dgregor@apple.com>2009-06-23 17:57:35 +0000
commit7e9e36a23e07dfb0d7ceda3e76450073c0534f35 (patch)
treeab89cfc44d7d6580e19a2d33465f6e167b75a382 /lib/ExecutionEngine/JIT/CMakeLists.txt
parent83a2129332250af4648e0501f93cabfa8873e1f4 (diff)
downloadllvm-7e9e36a23e07dfb0d7ceda3e76450073c0534f35.tar.gz
llvm-7e9e36a23e07dfb0d7ceda3e76450073c0534f35.tar.bz2
llvm-7e9e36a23e07dfb0d7ceda3e76450073c0534f35.tar.xz
Eliminate object-relinking support from CMake. Fixes PR 4429 and
cleans up the CMake-based build system a bit. Started by a patch from Xerxes RĂ„nby. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@73969 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ExecutionEngine/JIT/CMakeLists.txt')
-rw-r--r--lib/ExecutionEngine/JIT/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/ExecutionEngine/JIT/CMakeLists.txt b/lib/ExecutionEngine/JIT/CMakeLists.txt
index d7980d0772..e0c13a10f0 100644
--- a/lib/ExecutionEngine/JIT/CMakeLists.txt
+++ b/lib/ExecutionEngine/JIT/CMakeLists.txt
@@ -1,7 +1,7 @@
# TODO: Support other architectures. See Makefile.
add_definitions(-DENABLE_X86_JIT)
-add_partially_linked_object(LLVMJIT
+add_llvm_library(LLVMJIT
Intercept.cpp
JIT.cpp
JITDwarfEmitter.cpp