summaryrefslogtreecommitdiff
path: root/lib/ExecutionEngine/JIT/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2011-11-12 02:10:57 +0000
committerDaniel Dunbar <daniel@zuster.org>2011-11-12 02:10:57 +0000
commitb8ebca83f4dff04ba21cc97673003f0bd35a2e49 (patch)
treebbd5da231b9ff4baa53da5bc6f5e5ad15496378f /lib/ExecutionEngine/JIT/CMakeLists.txt
parent75f69e3a3dff78cb89ded1d6c96ccb65603a82d9 (diff)
downloadllvm-b8ebca83f4dff04ba21cc97673003f0bd35a2e49.tar.gz
llvm-b8ebca83f4dff04ba21cc97673003f0bd35a2e49.tar.bz2
llvm-b8ebca83f4dff04ba21cc97673003f0bd35a2e49.tar.xz
build: Attempt to rectify inconsistencies between CMake and LLVMBuild versions of explicit dependencies.
- The hope is that we have a tool/test to verify these are accurate (and tight) soon. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@144444 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ExecutionEngine/JIT/CMakeLists.txt')
-rw-r--r--lib/ExecutionEngine/JIT/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/ExecutionEngine/JIT/CMakeLists.txt b/lib/ExecutionEngine/JIT/CMakeLists.txt
index 92aa76a5cf..813ccced9a 100644
--- a/lib/ExecutionEngine/JIT/CMakeLists.txt
+++ b/lib/ExecutionEngine/JIT/CMakeLists.txt
@@ -12,10 +12,11 @@ add_llvm_library(LLVMJIT
)
add_llvm_library_dependencies(LLVMJIT
+ LLVMCodeGen
LLVMCore
LLVMExecutionEngine
+ LLVMMC
LLVMRuntimeDyld
LLVMSupport
LLVMTarget
- LLVMCodeGen
)