summaryrefslogtreecommitdiff
path: root/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Grosbach <grosbach@apple.com>2011-03-21 22:15:52 +0000
committerJim Grosbach <grosbach@apple.com>2011-03-21 22:15:52 +0000
commit6e56331ed99e5b96de940dfdc53e438eef521a2e (patch)
tree119dac47b658037637552736c9b634eaa2dcb3ba /lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
parentb99462117ebd4be41788346246d7935fc90a11ee (diff)
downloadllvm-6e56331ed99e5b96de940dfdc53e438eef521a2e.tar.gz
llvm-6e56331ed99e5b96de940dfdc53e438eef521a2e.tar.bz2
llvm-6e56331ed99e5b96de940dfdc53e438eef521a2e.tar.xz
Library-ize the dyld components of llvm-rtdyld.
Move the dynamic linking functionality of the llvm-rtdyld program into an ExecutionEngine support library. Update llvm-rtdyld to just load an object file into memory, use the library to process it, then run the _main() function, if one is found. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@128031 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt')
-rw-r--r--lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt b/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
new file mode 100644
index 0000000000..9e53f8757e
--- /dev/null
+++ b/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
@@ -0,0 +1,3 @@
+add_llvm_library(LLVMRuntimeDyld
+ RuntimeDyld.cpp
+ )