summaryrefslogtreecommitdiff
path: root/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaylor <andrew.kaylor@intel.com>2012-11-27 19:42:02 +0000
committerAndrew Kaylor <andrew.kaylor@intel.com>2012-11-27 19:42:02 +0000
commit927ba6a0b36b8219955a657545fcb1c863734993 (patch)
tree25b8bf6ceac6ae3009e7e9105b1f8f31474715a4 /lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
parent3c1cc3888bbfbb568dad296f577c63eba8999a72 (diff)
downloadllvm-927ba6a0b36b8219955a657545fcb1c863734993.tar.gz
llvm-927ba6a0b36b8219955a657545fcb1c863734993.tar.bz2
llvm-927ba6a0b36b8219955a657545fcb1c863734993.tar.xz
Moving SectionMemoryManager into RuntimeDyld and adding unit tests for it.
The SectionMemoryManager now supports (and requires) applying section-specific page permissions. Clients using this memory manager must call either MCJIT::finalizeObject() or SectionMemoryManager::applyPermissions() before executing JITed code. See r168718 for changes from the previous implementation. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@168721 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt')
-rw-r--r--lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt b/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
index cbf7cf14d4..728303ac4e 100644
--- a/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
+++ b/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
@@ -3,4 +3,5 @@ add_llvm_library(LLVMRuntimeDyld
RuntimeDyld.cpp
RuntimeDyldELF.cpp
RuntimeDyldMachO.cpp
+ SectionMemoryManager.cpp
)