summaryrefslogtreecommitdiff
path: root/lib/MC/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2014-05-03 19:57:04 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2014-05-03 19:57:04 +0000
commit930ca9843331c2cdce2a49517f661d60bfe61204 (patch)
treef434a95534279e21354ed733a6a6cbd95bfa4da5 /lib/MC/CMakeLists.txt
parent72e96a51bffcda773a9b8c11789a7018ea72c768 (diff)
downloadllvm-930ca9843331c2cdce2a49517f661d60bfe61204.tar.gz
llvm-930ca9843331c2cdce2a49517f661d60bfe61204.tar.bz2
llvm-930ca9843331c2cdce2a49517f661d60bfe61204.tar.xz
Fix pr19645.
The fix itself is fairly simple: move getAccessVariant to MCValue so that we replace the old weak expression evaluation with the far more general EvaluateAsRelocatable. This then requires that EvaluateAsRelocatable stop when it finds a non trivial reference kind. And that in turn requires the ELF writer to look harder for weak references. Last but not least, this found a case where we were being bug by bug compatible with gas and accepting an invalid input. I reported pr19647 to track it. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@207920 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/MC/CMakeLists.txt')
-rw-r--r--lib/MC/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/MC/CMakeLists.txt b/lib/MC/CMakeLists.txt
index 7b69c7a9e3..6a384c1a8e 100644
--- a/lib/MC/CMakeLists.txt
+++ b/lib/MC/CMakeLists.txt
@@ -16,7 +16,6 @@ add_llvm_library(LLVMMC
MCELF.cpp
MCELFObjectTargetWriter.cpp
MCELFStreamer.cpp
- MCFixup.cpp
MCFunction.cpp
MCExpr.cpp
MCExternalSymbolizer.cpp