summaryrefslogtreecommitdiff
path: root/lib/Object/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2013-08-08 22:27:13 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2013-08-08 22:27:13 +0000
commit081a1941b595f6294e4ce678fd61ef56a2ceb51e (patch)
tree45ac82225774a2894de7e3e4c4a83e5cf2d90dd5 /lib/Object/CMakeLists.txt
parent491d04969d9f29ed891c73238648853954ba4f81 (diff)
downloadllvm-081a1941b595f6294e4ce678fd61ef56a2ceb51e.tar.gz
llvm-081a1941b595f6294e4ce678fd61ef56a2ceb51e.tar.bz2
llvm-081a1941b595f6294e4ce678fd61ef56a2ceb51e.tar.xz
[Object] Split the ELF interface into 3 parts.
* ELFTypes.h contains template magic for defining types based on endianess, size, and alignment. * ELFFile.h defines the ELFFile class which provides low level ELF specific access. * ELFObjectFile.h contains ELFObjectFile which uses ELFFile to implement the ObjectFile interface. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@188022 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Object/CMakeLists.txt')
-rw-r--r--lib/Object/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Object/CMakeLists.txt b/lib/Object/CMakeLists.txt
index 2c2cc8e4fb..1f07cbba77 100644
--- a/lib/Object/CMakeLists.txt
+++ b/lib/Object/CMakeLists.txt
@@ -3,6 +3,7 @@ add_llvm_library(LLVMObject
Binary.cpp
COFFObjectFile.cpp
COFFYAML.cpp
+ ELF.cpp
ELFObjectFile.cpp
ELFYAML.cpp
Error.cpp