summaryrefslogtreecommitdiff
path: root/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2013-12-27 04:28:57 +0000
committerChandler Carruth <chandlerc@gmail.com>2013-12-27 04:28:57 +0000
commit5ff21b411149095abb421c1e1263341360072cec (patch)
treed34de93b7beaf2c032c7f26de8e85291c9b30495 /lib/Support/CMakeLists.txt
parent52b162375ad7f0e1d820ae959031ac70e254aa3b (diff)
downloadllvm-5ff21b411149095abb421c1e1263341360072cec.tar.gz
llvm-5ff21b411149095abb421c1e1263341360072cec.tar.bz2
llvm-5ff21b411149095abb421c1e1263341360072cec.tar.xz
Introduce a simple line-by-line iterator type into the Support library.
This is an iterator which you can build around a MemoryBuffer. It will iterate through the non-empty, non-comment lines of the buffer as a forward iterator. It should be small and reasonably fast (although it could be made much faster if anyone cares, I don't really...). This will be used to more simply support the text-based sample profile file format, and is largely based on the original patch by Diego. I've re-worked the style of it and separated it from the work of producing a MemoryBuffer from a file which both simplifies the interface and makes it easier to test. The style of the API follows the C++ standard naming conventions to fit in better with iterators in general, much like the Path and FileSystem interfaces follow standard-based naming conventions. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@198068 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Support/CMakeLists.txt')
-rw-r--r--lib/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Support/CMakeLists.txt b/lib/Support/CMakeLists.txt
index 3aecf3ffa4..cf4edff632 100644
--- a/lib/Support/CMakeLists.txt
+++ b/lib/Support/CMakeLists.txt
@@ -30,6 +30,7 @@ add_llvm_library(LLVMSupport
IntrusiveRefCntPtr.cpp
IsInf.cpp
IsNAN.cpp
+ LineIterator.cpp
Locale.cpp
LockFileManager.cpp
ManagedStatic.cpp