summaryrefslogtreecommitdiff
path: root/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Kramer <benny.kra@googlemail.com>2011-09-13 19:42:16 +0000
committerBenjamin Kramer <benny.kra@googlemail.com>2011-09-13 19:42:16 +0000
commit8c74f7f2991a10977fd5a003b2901b56eb2e19a8 (patch)
treee9c25ae260bcc06a6bbd5cd8c2fddd316352a1cc /lib/Support/CMakeLists.txt
parentdf24e1fb0812edd2bd33a3b279edb030dd30023d (diff)
downloadllvm-8c74f7f2991a10977fd5a003b2901b56eb2e19a8.tar.gz
llvm-8c74f7f2991a10977fd5a003b2901b56eb2e19a8.tar.bz2
llvm-8c74f7f2991a10977fd5a003b2901b56eb2e19a8.tar.xz
Add the DataExtractor utility class.
It is an endian-aware helper that can read data from a StringRef. It will come in handy for DWARF parsing. This class is inspired by LLDB's DataExtractor, but is stripped down to the bare minimum needed for DWARF. Comes with unit tests! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@139626 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Support/CMakeLists.txt')
-rw-r--r--lib/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Support/CMakeLists.txt b/lib/Support/CMakeLists.txt
index 80a237ac74..63a833c380 100644
--- a/lib/Support/CMakeLists.txt
+++ b/lib/Support/CMakeLists.txt
@@ -15,6 +15,7 @@ add_llvm_library(LLVMSupport
CommandLine.cpp
ConstantRange.cpp
CrashRecoveryContext.cpp
+ DataExtractor.cpp
Debug.cpp
DeltaAlgorithm.cpp
DAGDeltaAlgorithm.cpp