summaryrefslogtreecommitdiff
path: root/lib/System/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2009-07-27 17:55:55 +0000
committerDouglas Gregor <dgregor@apple.com>2009-07-27 17:55:55 +0000
commite34887d5d02e8bd42b414fb17f69c35b8d13695d (patch)
tree17bd1a3680999b9570c2396fefefe6a03320a842 /lib/System/CMakeLists.txt
parenta7defb7150ccd4a8c4ff302d5ad134029e50e700 (diff)
downloadllvm-e34887d5d02e8bd42b414fb17f69c35b8d13695d.tar.gz
llvm-e34887d5d02e8bd42b414fb17f69c35b8d13695d.tar.bz2
llvm-e34887d5d02e8bd42b414fb17f69c35b8d13695d.tar.xz
CMake: make sure that the *.inc files for libSystem show up in the resulting
project. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@77213 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/System/CMakeLists.txt')
-rw-r--r--lib/System/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/lib/System/CMakeLists.txt b/lib/System/CMakeLists.txt
index 8315f422b3..2945e33d5b 100644
--- a/lib/System/CMakeLists.txt
+++ b/lib/System/CMakeLists.txt
@@ -16,6 +16,29 @@ add_llvm_library(LLVMSystem
ThreadLocal.cpp
Threading.cpp
TimeValue.cpp
+ Unix/Alarm.inc
+ Unix/Host.inc
+ Unix/Memory.inc
+ Unix/Mutex.inc
+ Unix/Path.inc
+ Unix/Process.inc
+ Unix/Program.inc
+ Unix/RWMutex.inc
+ Unix/Signals.inc
+ Unix/ThreadLocal.inc
+ Unix/TimeValue.inc
+ Win32/Alarm.inc
+ Win32/DynamicLibrary.inc
+ Win32/Host.inc
+ Win32/Memory.inc
+ Win32/Mutex.inc
+ Win32/Path.inc
+ Win32/Process.inc
+ Win32/Program.inc
+ Win32/RWMutex.inc
+ Win32/Signals.inc
+ Win32/ThreadLocal.inc
+ Win32/TimeValue.inc
)
if( BUILD_SHARED_LIBS AND NOT WIN32 )