summaryrefslogtreecommitdiff
path: root/lib/System/CMakeLists.txt
diff options
context:
space:
mode:
authorJeffrey Yasskin <jyasskin@google.com>2009-07-01 18:11:20 +0000
committerJeffrey Yasskin <jyasskin@google.com>2009-07-01 18:11:20 +0000
commited1c0ffe0b2287deaee7cba7506c93aa34c6d4b7 (patch)
treeaacc869a6945fbd60630f775bd2530fa3d2eaed9 /lib/System/CMakeLists.txt
parentb1d7a5d1146c30a54002b7ab49daf024e3174b95 (diff)
downloadllvm-ed1c0ffe0b2287deaee7cba7506c93aa34c6d4b7.tar.gz
llvm-ed1c0ffe0b2287deaee7cba7506c93aa34c6d4b7.tar.bz2
llvm-ed1c0ffe0b2287deaee7cba7506c93aa34c6d4b7.tar.xz
Add a portable strerror*() wrapper, llvm::sys::StrError(). This includes the
Windows variant, strerror_s, but I couldn't test that. I'll update configure and config.h.in in a subsequent patch. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@74621 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/System/CMakeLists.txt')
-rw-r--r--lib/System/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/System/CMakeLists.txt b/lib/System/CMakeLists.txt
index 431629a14d..bf7a0c601e 100644
--- a/lib/System/CMakeLists.txt
+++ b/lib/System/CMakeLists.txt
@@ -3,6 +3,7 @@ add_llvm_library(LLVMSystem
Atomic.cpp
Disassembler.cpp
DynamicLibrary.cpp
+ Errno.cpp
Host.cpp
IncludeFile.cpp
Memory.cpp