summaryrefslogtreecommitdiff
path: root/lib/System/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-11-16 18:31:52 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-11-16 18:31:52 +0000
commitfae76d0734562b6422c51fe3207cca8a51666323 (patch)
treec6d48807beab1e46d8ac6c036ed955266686fdfa /lib/System/CMakeLists.txt
parentf93cbbd72ed15a6f0c2e03bfe7729e4b847566be (diff)
downloadllvm-fae76d0734562b6422c51fe3207cca8a51666323.tar.gz
llvm-fae76d0734562b6422c51fe3207cca8a51666323.tar.bz2
llvm-fae76d0734562b6422c51fe3207cca8a51666323.tar.xz
This is the first step in adding sane error handling support to LLVMSystem.
The system API's will be shifted over to returning an error_code, and returning other return values as out parameters to the function. Code that needs to check error conditions will use the errc enum values which are the same as the posix_errno defines (EBADF, E2BIG, etc...), and are compatable with the error codes in WinError.h due to some magic in system_error. An example would be: if (error_code ec = KillEvil("Java")) { // error_code can be converted to bool. handle_error(ec); } git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@119360 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/System/CMakeLists.txt')
-rw-r--r--lib/System/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/System/CMakeLists.txt b/lib/System/CMakeLists.txt
index ac2830e80a..16612ad88f 100644
--- a/lib/System/CMakeLists.txt
+++ b/lib/System/CMakeLists.txt
@@ -19,6 +19,7 @@ add_llvm_library(LLVMSystem
RWMutex.cpp
SearchForAddressOfSpecialSymbol.cpp
Signals.cpp
+ system_error.cpp
ThreadLocal.cpp
Threading.cpp
TimeValue.cpp
@@ -32,6 +33,7 @@ add_llvm_library(LLVMSystem
Unix/Program.inc
Unix/RWMutex.inc
Unix/Signals.inc
+ Unix/system_error.inc
Unix/ThreadLocal.inc
Unix/TimeValue.inc
Win32/Alarm.inc
@@ -44,6 +46,7 @@ add_llvm_library(LLVMSystem
Win32/Program.inc
Win32/RWMutex.inc
Win32/Signals.inc
+ Win32/system_error.inc
Win32/ThreadLocal.inc
Win32/TimeValue.inc
)