summaryrefslogtreecommitdiff
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-02-20 02:55:27 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-02-20 02:55:27 +0000
commit00d78f1348a5980a276bed8f9be09ce2412a6a12 (patch)
tree81597ac6d857f5ef9bb97a2341b7cfcb0dc68318 /lib/Target/CMakeLists.txt
parent7ac0199287f7ebfdb4c609b0d3fd5d7fb41d1ce8 (diff)
downloadllvm-00d78f1348a5980a276bed8f9be09ce2412a6a12.tar.gz
llvm-00d78f1348a5980a276bed8f9be09ce2412a6a12.tar.bz2
llvm-00d78f1348a5980a276bed8f9be09ce2412a6a12.tar.xz
Use explicit add_subdirectory's for LLVM target sublibraries instead
of testing for its presence at cmake time. This way the build automatically regenerates the makefiles when a svn update brings in a new sublibrary. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@126068 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
index fe9a126495..09b48ce632 100644
--- a/lib/Target/CMakeLists.txt
+++ b/lib/Target/CMakeLists.txt
@@ -22,30 +22,20 @@ set(LLVM_ENUM_DISASSEMBLERS "")
foreach(t ${LLVM_TARGETS_TO_BUILD})
message(STATUS "Targeting ${t}")
add_subdirectory(${t})
- add_subdirectory(${t}/TargetInfo)
set( td ${LLVM_MAIN_SRC_DIR}/lib/Target/${t} )
file(GLOB asmp_file "${td}/*AsmPrinter.cpp")
if( asmp_file )
set(LLVM_ENUM_ASM_PRINTERS
"${LLVM_ENUM_ASM_PRINTERS}LLVM_ASM_PRINTER(${t})\n")
endif()
- if( EXISTS ${td}/InstPrinter/CMakeLists.txt )
- add_subdirectory(${t}/InstPrinter)
- endif()
if( EXISTS ${td}/AsmParser/CMakeLists.txt )
- add_subdirectory(${t}/AsmParser)
set(LLVM_ENUM_ASM_PARSERS
"${LLVM_ENUM_ASM_PARSERS}LLVM_ASM_PARSER(${t})\n")
endif()
if( EXISTS ${td}/Disassembler/CMakeLists.txt )
- add_subdirectory(${t}/Disassembler)
set(LLVM_ENUM_DISASSEMBLERS
"${LLVM_ENUM_DISASSEMBLERS}LLVM_DISASSEMBLER(${t})\n")
endif()
- if( EXISTS ${td}/Utils/CMakeLists.txt )
- add_subdirectory(${td}/Utils)
- endif()
- set(CURRENT_LLVM_TARGET)
endforeach(t)
# Produce llvm/Config/AsmPrinters.def