summaryrefslogtreecommitdiff
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2012-11-28 02:35:09 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2012-11-28 02:35:09 +0000
commit11fad6ec660d2131e040ebdecc4433b359d05e5f (patch)
tree731026d366cd89def576dc58dcc74e88d3452f77 /lib/Target/CMakeLists.txt
parent6e1c4561e54da1f9d7052bcb4d985de513b4859c (diff)
downloadllvm-11fad6ec660d2131e040ebdecc4433b359d05e5f.tar.gz
llvm-11fad6ec660d2131e040ebdecc4433b359d05e5f.tar.bz2
llvm-11fad6ec660d2131e040ebdecc4433b359d05e5f.tar.xz
Move Target{Instr,Register}Info.cpp into lib/CodeGen.
The Target library is not allowed to depend on the large CodeGen library, but the TRI and TII classes provide abstract interfaces that require both caller and callee to link to CodeGen. The implementation files for these classes provide default implementations of some of the hooks. These methods may need to reference CodeGen, so they belong in that library. We already have a number of methods implemented in the TargetInstrInfoImpl sub-class because of that. I will merge that class into the parent next. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@168758 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
index a85acaaa14..c87a33a8b9 100644
--- a/lib/Target/CMakeLists.txt
+++ b/lib/Target/CMakeLists.txt
@@ -1,14 +1,12 @@
add_llvm_library(LLVMTarget
Mangler.cpp
Target.cpp
- TargetInstrInfo.cpp
TargetIntrinsicInfo.cpp
TargetJITInfo.cpp
TargetLibraryInfo.cpp
TargetLoweringObjectFile.cpp
TargetMachine.cpp
TargetMachineC.cpp
- TargetRegisterInfo.cpp
TargetSubtargetInfo.cpp
TargetTransformImpl.cpp
)