summaryrefslogtreecommitdiff
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2011-07-22 08:16:53 +0000
committerChandler Carruth <chandlerc@gmail.com>2011-07-22 08:16:53 +0000
commit48ac8e9be70eb94217182dfaac23e2878b9b7e5a (patch)
treec7ab50edd120280917a5cbf7657abb5cfcfc2ad8 /lib/Target/CMakeLists.txt
parent5509403bb28b0127fc333429282e8d7a2d14b79d (diff)
downloadllvm-48ac8e9be70eb94217182dfaac23e2878b9b7e5a.tar.gz
llvm-48ac8e9be70eb94217182dfaac23e2878b9b7e5a.tar.bz2
llvm-48ac8e9be70eb94217182dfaac23e2878b9b7e5a.tar.xz
Move TargetRegistry.cpp from lib/Support to lib/Target where it belongs.
The header file was already properly located. The previous need for it in Support had to do with the version string printing which was fixed in r135757. Also update build dependencies where libraries that needed the functionality of the Target library (in the form of the TargetRegistry) were picking it up via Support. This is pretty pervasive, essentially every TargetInfo library (ARMInfo, etc) uses TargetRegistry, making it depend on Target. All of these were previously just sneaking by. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@135760 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
index b0989b2622..a31f041474 100644
--- a/lib/Target/CMakeLists.txt
+++ b/lib/Target/CMakeLists.txt
@@ -11,6 +11,7 @@ add_llvm_library(LLVMTarget
TargetLoweringObjectFile.cpp
TargetMachine.cpp
TargetRegisterInfo.cpp
+ TargetRegistry.cpp
TargetSubtargetInfo.cpp
)