summaryrefslogtreecommitdiff
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
authorAnders Waldenborg <anders@0x63.nu>2013-10-15 12:08:59 +0000
committerAnders Waldenborg <anders@0x63.nu>2013-10-15 12:08:59 +0000
commit6480db4b3afb0adb0ffcedc6e88e3b3f394a86cf (patch)
treefb5dae0bf434c72c8d6ec1c934d33ab1fdb8aa2a /lib/Target/CMakeLists.txt
parentf8f993b675568ea6380ad141371c67679a1b9ac4 (diff)
downloadllvm-6480db4b3afb0adb0ffcedc6e88e3b3f394a86cf.tar.gz
llvm-6480db4b3afb0adb0ffcedc6e88e3b3f394a86cf.tar.bz2
llvm-6480db4b3afb0adb0ffcedc6e88e3b3f394a86cf.tar.xz
Add AllTargetsBindings sublibrary instead of having static inlines in the llvm-c headers.
This new library will be linked in when using the "all-targets" component and contains the LLVMInitializeAll* functions. This means that those functions will exist as real symbols in the shared library, and can therefore can be called from bindings that are using ffi the shared library. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@192690 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
index 02ac493b42..861c999c6b 100644
--- a/lib/Target/CMakeLists.txt
+++ b/lib/Target/CMakeLists.txt
@@ -14,3 +14,5 @@ foreach(t ${LLVM_TARGETS_TO_BUILD})
message(STATUS "Targeting ${t}")
add_subdirectory(${t})
endforeach()
+
+add_subdirectory("AllTargetsBindings")