summaryrefslogtreecommitdiff
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Lewycky <nicholas@mxc.ca>2011-12-10 22:34:41 +0000
committerNick Lewycky <nicholas@mxc.ca>2011-12-10 22:34:41 +0000
commitb3ffe102fe35b4e4ee595c30b54b335e653310a9 (patch)
tree41d474c09e513b644916f2fba5e65714eda5fe8f /lib/Target/CMakeLists.txt
parent59164b731b36a1018a8ac241b0f2dc0a08dfec90 (diff)
downloadllvm-b3ffe102fe35b4e4ee595c30b54b335e653310a9.tar.gz
llvm-b3ffe102fe35b4e4ee595c30b54b335e653310a9.tar.bz2
llvm-b3ffe102fe35b4e4ee595c30b54b335e653310a9.tar.xz
Refactor the implementation of the TargetOptions out of TargetMachine, taking
the only parts of TM that depends on CodeGen headers with it. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@146334 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
index cc2462551e..28f1ebbdab 100644
--- a/lib/Target/CMakeLists.txt
+++ b/lib/Target/CMakeLists.txt
@@ -9,6 +9,7 @@ add_llvm_library(LLVMTarget
TargetLibraryInfo.cpp
TargetLoweringObjectFile.cpp
TargetMachine.cpp
+ TargetOptions.cpp
TargetRegisterInfo.cpp
TargetSubtargetInfo.cpp
)