summaryrefslogtreecommitdiff
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2011-02-18 21:50:34 +0000
committerChris Lattner <sabre@nondot.org>2011-02-18 21:50:34 +0000
commitce99120084f549a523213064648662a704e8b789 (patch)
tree302ee420dae97f757a2da56a2c84fbc849a8e742 /lib/Target/CMakeLists.txt
parentd78b7891104e7110d6e71646f98c4f07d814e6b3 (diff)
downloadllvm-ce99120084f549a523213064648662a704e8b789.tar.gz
llvm-ce99120084f549a523213064648662a704e8b789.tar.bz2
llvm-ce99120084f549a523213064648662a704e8b789.tar.xz
introduce a new TargetLibraryInfo pass, which transformations can use to
query about available library functions. For now this just has memset_pattern16, which exists on darwin, but it can be extended for a bunch of other things in the future. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@125965 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
index 4d02d1e4a5..f7a98664a3 100644
--- a/lib/Target/CMakeLists.txt
+++ b/lib/Target/CMakeLists.txt
@@ -9,6 +9,7 @@ add_llvm_library(LLVMTarget
TargetFrameLowering.cpp
TargetInstrInfo.cpp
TargetIntrinsicInfo.cpp
+ TargetLibraryInfo.cpp
TargetLoweringObjectFile.cpp
TargetMachine.cpp
TargetRegisterInfo.cpp