summaryrefslogtreecommitdiff
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Cheng <evan.cheng@apple.com>2011-07-09 05:47:46 +0000
committerEvan Cheng <evan.cheng@apple.com>2011-07-09 05:47:46 +0000
commitffc0e73046f737d75e0a62b3a83ef19bcef111e3 (patch)
tree1f82f6a0b1c1a743dd4c10377858004988a47262 /lib/Target/CMakeLists.txt
parent4f4a6fcd165293c347a42b543e5e55aa42a09bb2 (diff)
downloadllvm-ffc0e73046f737d75e0a62b3a83ef19bcef111e3.tar.gz
llvm-ffc0e73046f737d75e0a62b3a83ef19bcef111e3.tar.bz2
llvm-ffc0e73046f737d75e0a62b3a83ef19bcef111e3.tar.xz
Change createAsmParser to take a MCSubtargetInfo instead of triple,
CPU, and feature string. Parsing some asm directives can change subtarget state (e.g. .code 16) and it must be reflected in other modules (e.g. MCCodeEmitter). That is, the MCSubtargetInfo instance must be shared. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@134795 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
index f982316fc0..9c684a2265 100644
--- a/lib/Target/CMakeLists.txt
+++ b/lib/Target/CMakeLists.txt
@@ -54,3 +54,9 @@ configure_file(
${LLVM_MAIN_INCLUDE_DIR}/llvm/Config/Disassemblers.def.in
${LLVM_BINARY_DIR}/include/llvm/Config/Disassemblers.def
)
+
+# Produce llvm/Config/MCSubtargetInfos.def
+configure_file(
+ ${LLVM_MAIN_INCLUDE_DIR}/llvm/Config/MCSubtargetInfos.def.in
+ ${LLVM_BINARY_DIR}/include/llvm/Config/MCSubtargtInfos.def
+ )