summaryrefslogtreecommitdiff
path: root/lib/Target/Mips/CMakeLists.txt
diff options
context:
space:
mode:
authorReed Kotler <rkotler@mips.com>2014-04-25 18:36:38 +0000
committerReed Kotler <rkotler@mips.com>2014-04-25 18:36:38 +0000
commit4870dae19fb20aeba5f0f7a2f8498fb4579ca3fd (patch)
tree8c205dfeca66b7bbf1d08326c560f29380f44aa4 /lib/Target/Mips/CMakeLists.txt
parent5410b5acda1c8a9726d008a46b382eaa83a52443 (diff)
downloadllvm-4870dae19fb20aeba5f0f7a2f8498fb4579ca3fd.tar.gz
llvm-4870dae19fb20aeba5f0f7a2f8498fb4579ca3fd.tar.bz2
llvm-4870dae19fb20aeba5f0f7a2f8498fb4579ca3fd.tar.xz
enable fast isel tablegen files for Mips
Reviewers: dsanders Reviewed By: dsanders Differential Revision: http://reviews.llvm.org/D3498 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@207256 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/Mips/CMakeLists.txt')
-rw-r--r--lib/Target/Mips/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/Mips/CMakeLists.txt b/lib/Target/Mips/CMakeLists.txt
index ff4dd3ec3e..bf67d71b0a 100644
--- a/lib/Target/Mips/CMakeLists.txt
+++ b/lib/Target/Mips/CMakeLists.txt
@@ -7,6 +7,7 @@ tablegen(LLVM MipsGenCodeEmitter.inc -gen-emitter)
tablegen(LLVM MipsGenMCCodeEmitter.inc -gen-emitter -mc-emitter)
tablegen(LLVM MipsGenAsmWriter.inc -gen-asm-writer)
tablegen(LLVM MipsGenDAGISel.inc -gen-dag-isel)
+tablegen(LLVM MipsGenFastISel.inc -gen-fast-isel)
tablegen(LLVM MipsGenCallingConv.inc -gen-callingconv)
tablegen(LLVM MipsGenSubtargetInfo.inc -gen-subtarget)
tablegen(LLVM MipsGenAsmMatcher.inc -gen-asm-matcher)