summaryrefslogtreecommitdiff
path: root/lib/Target/Mips/CMakeLists.txt
diff options
context:
space:
mode:
authorAkira Hatanaka <ahatanaka@mips.com>2012-09-27 01:59:07 +0000
committerAkira Hatanaka <ahatanaka@mips.com>2012-09-27 01:59:07 +0000
commitcc46fe591af10c193c17323547a3dd7cc00c925d (patch)
treeb557338cb9818b31101b132dcbe51860a0c6ee32 /lib/Target/Mips/CMakeLists.txt
parent7e105bcc3ab0e0e8ddc7617b37a9fe9cd1d0b1bf (diff)
downloadllvm-cc46fe591af10c193c17323547a3dd7cc00c925d.tar.gz
llvm-cc46fe591af10c193c17323547a3dd7cc00c925d.tar.bz2
llvm-cc46fe591af10c193c17323547a3dd7cc00c925d.tar.xz
MIPS DSP: add code necessary for pseudo instruction lowering.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@164747 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/Mips/CMakeLists.txt')
-rw-r--r--lib/Target/Mips/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/Mips/CMakeLists.txt b/lib/Target/Mips/CMakeLists.txt
index 0f84358e26..7dec066fb6 100644
--- a/lib/Target/Mips/CMakeLists.txt
+++ b/lib/Target/Mips/CMakeLists.txt
@@ -11,6 +11,7 @@ tablegen(LLVM MipsGenCallingConv.inc -gen-callingconv)
tablegen(LLVM MipsGenSubtargetInfo.inc -gen-subtarget)
tablegen(LLVM MipsGenEDInfo.inc -gen-enhanced-disassembly-info)
tablegen(LLVM MipsGenAsmMatcher.inc -gen-asm-matcher)
+tablegen(LLVM MipsGenMCPseudoLowering.inc -gen-pseudo-lowering)
add_public_tablegen_target(MipsCommonTableGen)
add_llvm_target(MipsCodeGen