summaryrefslogtreecommitdiff
path: root/lib/Target/Mips/CMakeLists.txt
diff options
context:
space:
mode:
authorAkira Hatanaka <ahatanaka@mips.com>2012-07-31 22:50:19 +0000
committerAkira Hatanaka <ahatanaka@mips.com>2012-07-31 22:50:19 +0000
commitcdb3ba71ce550c5a41c84c3678225a39d6f0a414 (patch)
treeb0d0c70bbaa9f09fc6ade9c6ff6fd113d231da53 /lib/Target/Mips/CMakeLists.txt
parentd7122b8d3c48eab05d425c99fee53cde07feafe4 (diff)
downloadllvm-cdb3ba71ce550c5a41c84c3678225a39d6f0a414.tar.gz
llvm-cdb3ba71ce550c5a41c84c3678225a39d6f0a414.tar.bz2
llvm-cdb3ba71ce550c5a41c84c3678225a39d6f0a414.tar.xz
Add definitions of two subclasses of MipsFrameLowering, Mips16FrameLowering and
MipsSEFrameLowering. Implement MipsSEFrameLowering::hasReservedCallFrame. Call frames will not be reserved if there is a call with a large call frame or there are variable sized objects on the stack. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@161090 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/Mips/CMakeLists.txt')
-rw-r--r--lib/Target/Mips/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/Target/Mips/CMakeLists.txt b/lib/Target/Mips/CMakeLists.txt
index 275279c452..db2fde9d78 100644
--- a/lib/Target/Mips/CMakeLists.txt
+++ b/lib/Target/Mips/CMakeLists.txt
@@ -13,6 +13,7 @@ tablegen(LLVM MipsGenEDInfo.inc -gen-enhanced-disassembly-info)
add_public_tablegen_target(MipsCommonTableGen)
add_llvm_target(MipsCodeGen
+ Mips16FrameLowering.cpp
Mips16InstrInfo.cpp
MipsAnalyzeImmediate.cpp
MipsAsmPrinter.cpp
@@ -27,6 +28,7 @@ add_llvm_target(MipsCodeGen
MipsMCInstLower.cpp
MipsMachineFunction.cpp
MipsRegisterInfo.cpp
+ MipsSEFrameLowering.cpp
MipsSEInstrInfo.cpp
MipsSubtarget.cpp
MipsTargetMachine.cpp