summaryrefslogtreecommitdiff
path: root/lib/Target/Mips/Disassembler/CMakeLists.txt
diff options
context:
space:
mode:
authorAkira Hatanaka <ahatanaka@mips.com>2012-04-03 02:20:58 +0000
committerAkira Hatanaka <ahatanaka@mips.com>2012-04-03 02:20:58 +0000
commit885020a7a7299c0cfc12f691bc298e0f41d02190 (patch)
tree349647d7856d054e2c63f7f627eb0553ac31ed25 /lib/Target/Mips/Disassembler/CMakeLists.txt
parent5aeda3f07684e555f19813e41b7fc101434cfe64 (diff)
downloadllvm-885020a7a7299c0cfc12f691bc298e0f41d02190.tar.gz
llvm-885020a7a7299c0cfc12f691bc298e0f41d02190.tar.bz2
llvm-885020a7a7299c0cfc12f691bc298e0f41d02190.tar.xz
MIPS disassembler support.
Patch by Vladimir Medic. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@153924 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/Mips/Disassembler/CMakeLists.txt')
-rw-r--r--lib/Target/Mips/Disassembler/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/lib/Target/Mips/Disassembler/CMakeLists.txt b/lib/Target/Mips/Disassembler/CMakeLists.txt
new file mode 100644
index 0000000000..4b2f6be49e
--- /dev/null
+++ b/lib/Target/Mips/Disassembler/CMakeLists.txt
@@ -0,0 +1,30 @@
+include_directories( ${CMAKE_CURRENT_BINARY_DIR}/.. ${CMAKE_CURRENT_SOURCE_DIR}/.. )
+
+add_llvm_library(LLVMMipsDisassembler
+ MipsDisassembler.cpp
+ )
+
+# workaround for hanging compilation on MSVC9 and 10
+if( MSVC_VERSION EQUAL 1400 OR MSVC_VERSION EQUAL 1500 OR MSVC_VERSION EQUAL 1600 )
+set_property(
+ SOURCE MipsDisassembler.cpp
+ PROPERTY COMPILE_FLAGS "/Od"
+ )
+endif()
+
+add_dependencies(LLVMMipsDisassembler MipsCommonTableGen)
+include_directories( ${CMAKE_CURRENT_BINARY_DIR}/.. ${CMAKE_CURRENT_SOURCE_DIR}/.. )
+
+add_llvm_library(LLVMMipsDisassembler
+ MipsDisassembler.cpp
+ )
+
+# workaround for hanging compilation on MSVC9 and 10
+if( MSVC_VERSION EQUAL 1400 OR MSVC_VERSION EQUAL 1500 OR MSVC_VERSION EQUAL 1600 )
+set_property(
+ SOURCE MipsDisassembler.cpp
+ PROPERTY COMPILE_FLAGS "/Od"
+ )
+endif()
+
+add_dependencies(LLVMMipsDisassembler MipsCommonTableGen)