summaryrefslogtreecommitdiff
path: root/lib/Target/NVPTX/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Holewinski <jholewinski@nvidia.com>2013-05-31 12:14:49 +0000
committerJustin Holewinski <jholewinski@nvidia.com>2013-05-31 12:14:49 +0000
commit5443e7d79044f3198f2da044f1b389b40d9bea6f (patch)
tree2af410aedc2eb4f9a78443029eb71da208562589 /lib/Target/NVPTX/CMakeLists.txt
parent7ae921dbec5db9823c89fa736b2a4c3afe163e4f (diff)
downloadllvm-5443e7d79044f3198f2da044f1b389b40d9bea6f.tar.gz
llvm-5443e7d79044f3198f2da044f1b389b40d9bea6f.tar.bz2
llvm-5443e7d79044f3198f2da044f1b389b40d9bea6f.tar.xz
[NVPTX] Re-enable support for virtual registers in the final output
Now that 3.3 is branched, we are re-enabling virtual registers to help iron out bugs before the next release. Some of the post-RA passes do not play well with virtual registers, so we disable them for now. The needed functionality of the PrologEpilogInserter pass is copied to a new backend-specific NVPTXPrologEpilog pass. The test for this commit is not breaking the existing tests. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@182998 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/NVPTX/CMakeLists.txt')
-rw-r--r--lib/Target/NVPTX/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/NVPTX/CMakeLists.txt b/lib/Target/NVPTX/CMakeLists.txt
index 735ca9b6b7..a8293da760 100644
--- a/lib/Target/NVPTX/CMakeLists.txt
+++ b/lib/Target/NVPTX/CMakeLists.txt
@@ -24,6 +24,7 @@ set(NVPTXCodeGen_sources
NVPTXUtilities.cpp
NVVMReflect.cpp
NVPTXGenericToNVVM.cpp
+ NVPTXPrologEpilogPass.cpp
)
add_llvm_target(NVPTXCodeGen ${NVPTXCodeGen_sources})