summaryrefslogtreecommitdiff
path: root/lib/Target/NVPTX/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2013-08-06 06:38:37 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2013-08-06 06:38:37 +0000
commit8e1d64666f493e4994b26a390bec1290a5d94b96 (patch)
treedb5269f4ee6baddf7871c704ca1ac8cd758a1dc7 /lib/Target/NVPTX/CMakeLists.txt
parentaa0f420567240fda76a57c25cdfd8d49376c0e76 (diff)
downloadllvm-8e1d64666f493e4994b26a390bec1290a5d94b96.tar.gz
llvm-8e1d64666f493e4994b26a390bec1290a5d94b96.tar.bz2
llvm-8e1d64666f493e4994b26a390bec1290a5d94b96.tar.xz
Target/*/CMakeLists.txt: Add the dependency to CommonTableGen explicitly for each corresponding CodeGen.
Without explicit dependencies, both per-file action and in-CommonTableGen action could run in parallel. It races to emit *.inc files simultaneously. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@187780 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/NVPTX/CMakeLists.txt')
-rw-r--r--lib/Target/NVPTX/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Target/NVPTX/CMakeLists.txt b/lib/Target/NVPTX/CMakeLists.txt
index a8293da760..be8d323c38 100644
--- a/lib/Target/NVPTX/CMakeLists.txt
+++ b/lib/Target/NVPTX/CMakeLists.txt
@@ -29,7 +29,7 @@ set(NVPTXCodeGen_sources
add_llvm_target(NVPTXCodeGen ${NVPTXCodeGen_sources})
-add_dependencies(LLVMNVPTXCodeGen intrinsics_gen)
+add_dependencies(LLVMNVPTXCodeGen NVPTXCommonTableGen intrinsics_gen)
add_subdirectory(TargetInfo)
add_subdirectory(InstPrinter)