summaryrefslogtreecommitdiff
path: root/lib/Target/SystemZ/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2009-07-20 00:24:17 +0000
committerDaniel Dunbar <daniel@zuster.org>2009-07-20 00:24:17 +0000
commit3f189a3eb40208c75ea33cf75e7183a48087541a (patch)
treed1a9cf95962f1af1798e9cd28252346b6a52e163 /lib/Target/SystemZ/CMakeLists.txt
parentfbb47eeac4f8a61d1f176373b37bd9cd755815f9 (diff)
downloadllvm-3f189a3eb40208c75ea33cf75e7183a48087541a.tar.gz
llvm-3f189a3eb40208c75ea33cf75e7183a48087541a.tar.bz2
llvm-3f189a3eb40208c75ea33cf75e7183a48087541a.tar.xz
CMake support for SystemZ.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@76384 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/SystemZ/CMakeLists.txt')
-rw-r--r--lib/Target/SystemZ/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/lib/Target/SystemZ/CMakeLists.txt b/lib/Target/SystemZ/CMakeLists.txt
new file mode 100644
index 0000000000..18d62732c4
--- /dev/null
+++ b/lib/Target/SystemZ/CMakeLists.txt
@@ -0,0 +1,23 @@
+set(LLVM_TARGET_DEFINITIONS SystemZ.td)
+
+tablegen(SystemZGenRegisterInfo.h.inc -gen-register-desc-header)
+tablegen(SystemZGenRegisterNames.inc -gen-register-enums)
+tablegen(SystemZGenRegisterInfo.inc -gen-register-desc)
+tablegen(SystemZGenInstrNames.inc -gen-instr-enums)
+tablegen(SystemZGenInstrInfo.inc -gen-instr-desc)
+tablegen(SystemZGenAsmWriter.inc -gen-asm-writer)
+tablegen(SystemZGenDAGISel.inc -gen-dag-isel)
+tablegen(SystemZGenCallingConv.inc -gen-callingconv)
+tablegen(SystemZGenSubtarget.inc -gen-subtarget)
+
+add_llvm_target(SystemZCodeGen
+ SystemZISelDAGToDAG.cpp
+ SystemZISelLowering.cpp
+ SystemZInstrInfo.cpp
+ SystemZRegisterInfo.cpp
+ SystemZSubtarget.cpp
+ SystemZTargetAsmInfo.cpp
+ SystemZTargetMachine.cpp
+ )
+
+target_link_libraries (LLVMSystemZCodeGen LLVMSelectionDAG)